Google не будет исправлять уязвимости в старых версиях Android

27.01.2015 13:05
Технологии

Компания Google официально признала, что больше не будет устранять ошибки в системе безопасности веб-браузера, установленного в некоторых старых версиях платформы Android.

Компания Google официально признала, что больше не будет устранять ошибки в системе безопасности веб-браузера, установленного в некоторых старых версиях платформы Android. Об этом глава по безопасности Android Адриан Людвиг написал на своей странице в Google+.

На прошлой неделе The Wall Street Journal сообщил о том, что Google, по всей видимости, больше не исправляет ошибки в браузере, по умолчанию используемом в устройствах на базе Android 4.3 Jelly Bean и более ранних версий платформы. Это ставит под угрозу взлома примерно две трети пользователей Android-устройств, которых всего насчитывается свыше миллиарда.

«Поддержка программного обеспечения в актуальном виде — одна из главных проблем специалистов по инфобезопасности. Однако лишь WebKit состоит из более 5 миллионов строк кода, причем сотни разработчиков вносят тысячи дополнений каждый месяц. Поэтому в некоторых случаях выпуск исправлений для уязвимостей в разделах WebKit более чем двухлетней давности требует изменений значительной части кода и больше не имеет смысла в плане безопасности», — пишет представитель Google.

В то же время Google продолжит выпускать обновления системы безопасности для браузера в Android 4.4 KitKat, которую компания выпустила в октябре 2013 года, а также в Android 5.0 Lollipop, выпущенной в ноябре 2014 года. Кроме того, проблема не затронет пользователей, установивших на устройства на более ранних версиях платформы альтернативные браузеры — например, Google Chrome или Mozilla Firefox.